Unhandled exception/screwy level
#1
So I was making a simple test level in Blender. Hours of aggression therapy for...

Naught. It looks nothing like it was supposed to look like. There where supposed to be boxes you needed to climb, a tree, and a small swimming hole. It looks like Giratina, the deity of antimatter, tore the place up. There were also no textures present.


And when I tried to save the level, I get an Unhandled Exception warning saying that the index was out of range, that it needed to be non negative and less than the size of the collection with Parameter Name Index.


Note that this time I am using a Windows Laptop and I used Blender instead of Sketchup.

If someone could assist me and tell me where I went horribly, HORRIBLY, H O R R I B L Y wrong, thanks are the reward, and maybe I might be one broken-legged step towards making my hack.


Update; Thanks to BanjoFreak’s advice, the model now loses the error messages it once pertained endlessly!

All is not right, however. Whenever I try to open the ROM, PJ64 freezes. I am using its 8MB setting, but it still won’t work. So this means I will require extra help. If anybody is willing to assist me, thanks in advance!


-The Lanky Wubbox, having major technical difficulties.

(Zipped file for Jombo ONLY.)


Attached Files
.zip   RatherMediocreTestLevel.zip (Size: 168.88 KB / Downloads: 3)
Reply
#2
Use textures, not materials, make sure triangulate is checked when you export to obj. zip and upload your .blend file.
Reply
#3
(06-09-2018, 10:12 PM)jombo23 Wrote: Use textures, not materials, make sure triangulate is checked when you export to obj. zip and upload your .blend file.

So I used textures and they still aren’t showing up. Do I do World Textures or something else?
Reply
#4
Just plain textures, nothing fancy. Please upload or pm me your blend file and textures zipped.
Reply
#5
(06-12-2018, 06:13 PM)jombo23 Wrote: Just plain textures, nothing fancy. Please upload or pm me your blend file and textures zipped.

I edited the thread so it has the .zip file with the Blend file and the textures.

Note that the level will be pathetically simple, as a Test Level usually is.
Reply
#6
youre texture file paths are crazy. Can you upload the obj and mtl as well?
Reply
#7
(06-12-2018, 06:56 PM)jombo23 Wrote: youre texture file paths are crazy. Can you upload the obj and mtl as well?

I did so. It was added to the zip. I just am unaware how to un-crazy those texture file paths.
Reply
#8
Hey Lanky!

This might help when exporting. Under the Export OBJ Settings panel on the left side after selecting "Export as... Wavefront(obj)", choose these options to tighten up your OBJs just a bit.

The reason I suggest this is because when you set the path mode to "copy" at the bottom, your file makes a copy of the textures present and sticks them in the same folder as the file you export. It gets a bit messy to look at, but that's the easiest way to get rid of your exports showing up solid white. Plus, it should get rid of your error code, too!

The other options selected are explained as well. You shouldn't have to check anything else, but at least match your settings to these.

Y Up means that the orientation will be saved with the Y axis appearing vertically. This is necessary because while Blender views your models on the XY plane with Z shown vertical, Banjo's Backpack handles the models as the N64 Engine sees them, which is on the XZ plane with Y shown vertical. So it's just orienting your model. 

Triangulate Faces is selected because without this, the Nintendo 64 has a hard time understanding quads. So faces may appear broken, or simply put, not at all. It's easier to select "Triangulate Faces" to smooth up your images and make your models come out looking like they should. 

Hope this helps!


Attached Files Thumbnail(s)
   
Reply
#9
(06-14-2018, 10:49 PM)BanjoFreak12 Wrote: Hey Lanky!

This might help when exporting. Under the Export OBJ Settings panel on the left side after selecting "Export as... Wavefront(obj)", choose these options to tighten up your OBJs just a bit.

The reason I suggest this is because when you set the path mode to "copy" at the bottom, your file makes a copy of the textures present and sticks them in the same folder as the file you export. It gets a bit messy to look at, but that's the easiest way to get rid of your exports showing up solid white. Plus, it should get rid of your error code, too!

The other options selected are explained as well. You shouldn't have to check anything else, but at least match your settings to these.

Y Up means that the orientation will be saved with the Y axis appearing vertically. This is necessary because while Blender views your models on the XY plane with Z shown vertical, Banjo's Backpack handles the models as the N64 Engine sees them, which is on the XZ plane with Y shown vertical. So it's just orienting your model. 

Triangulate Faces is selected because without this, the Nintendo 64 has a hard time understanding quads. So faces may appear broken, or simply put, not at all. It's easier to select "Triangulate Faces" to smooth up your images and make your models come out looking like they should. 

Hope this helps!

Thanks for the assistance in this situation!
Reply




Users browsing this thread: 1 Guest(s)